【IOS】VLAN

VLANの概要及び設定方法を説明します。VLAN IDの作成と適用、トランクリンクの設定、VLAN間ルーティングなどを取り上げます。設定の例を載せていますので、実機やPacket Tracer等を用いて実践してみてください。質問などありましたら、お気軽にどうぞ。

スタティックVLANとダイナミックVLAN

スタティックVLAN

ポートベースVLANと呼ばれる方式のことである。
手動でポートごとにVLANを定義する。

ダイナミックVLAN

VLANの割り当てを自動的に決定する。
MAC(アドレス)ベースVLAN、プロトコルベースVLANなどの方式がこれにあたる。
Ciscoネットワークでは、VMPS(VLAN Management Policy Server)サービスというVLANを管理する技術がある。

VLANの識別

アクセスリンク

1つのVLANだけに属している。PC等の機器を接続するリンクに適用する。

トランクリンク

複数のVLANに属している。スイッチ間を接続するリンクに適用する。

ISL(Inter-Switch Link)

Cisco独自のトラッキングプロトコル。26bytesのISLヘッダと4bytesのFCS(Frame Check Sequence)を追加する。

IEEE802.1Q

IEEE標準のトラッキングプロトコル。4bytesのタグを追加する。ネイティブVLAN(デフォルトは1)が規定されており、ネイティブVLANフレームを転送するときはタグが追加されない。

VLANの設定コマンド

VLANの作成

(config)# vlan [vlan-id]
(config-vlan)# name [vlan-name]   ※VLANの名前の設定は必須ではない

インタフェースへの適用

(config-if)# switchport mode access
(config-if)# switchport access vlan [vlan-id]

複数のインタフェースに同じVLANを適用する場合、rangeコマンドによりまとめて設定することができる。

(config)# interface range fastethernet 0/0-23 ※ポート0から23までを設定
(config-if-range)# switchport mode access
(config-if-range)# switchport access vlan [vlan-id]

トランクリンクの設定

(config-if)# switchport trunk encapsulation {dot1q|isl} ※dot1qがデフォルト値
(config-if)# switchport mode trunk

VLANの設定の例

VLAN ID の作成と適用

【VLANの作成】スイッチ:SW1及びSW2及びSW3

SW1:(config)# vlan 10
SW1:(config-vlan)# name GROUP10
SW1:(config-vlan)# vlan 20
SW1:(config-vlan)# name GROUP20

【インターフェースへの適用】スイッチ:SW1及びSW2

SW1:(config)# interface fastethernet 0/0
SW1:(config-if)# switchport mode access
SW1:(config-if)# switchport access vlan 10
SW1:(config)# interface fastethernet 0/1
SW1:(config-if)# switchport mode access
SW1:(config-if)# switchport access vlan 20

トランクリンクの設定

スイッチ:SW1及びSW2

SW1(config)# interface fastethernet 0/23
SW1(config-if)# switchport trunk encapsulation dot1q ※デフォルト値のため省略可
SW1(config-if)# switchport mode trunk

スイッチ:SW3

SW3(config)# interface range fastethernet 0/0-1
SW3#(config-if-range)# switchport trunk encapsulation dot1q
SW3(config-if-range)# switchport mode trunk

※トランクリンクに流すVLANトラフィックを指定することもできる
(config-if)# switchport trunk allowed vlan [vlan-id]

VLANの確認

【VLANの確認】スイッチ:SW1及びSW2

【トランクリンクの確認】スイッチ:SW1及びSW2及びSW3

SW1#show interfaces trunk
PortModeEncapsulationStatusNative vlan
Fa0/23on802.1qtrunking1
[省略]
(※SW2も同様)
SW3#show interfaces trunk
PortModeEncapsulationStatusNative vlan
Fa0/0on802.1qtrunking1
Fa0/1on802.1qtrunking1
[省略]

ルータによるVLAN間ルーティング

ルータの物理インターフェースごとに異なるVLANを収容する方法が考えられるが、ルータのインターフェース数よりも多くのVLANを使用する場合は適用できない。その場合、1つの物理インターフェースだけでVLAN間ルーティングを可能にする方法がある。これを「棒上のルータ」(router-on-a-stick)と呼ぶ。※トランク対応ルータであることが条件となる。

VLAN間ルーティングの設定の例

VLAN間ルーティング

ルータの設定

R1(config)#interface gigabitEthernet 0/0.1
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0

R1(config)#interface gigabitEthernet 0/0.2
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0

スイッチ:SW3の設定

SW3(config)#interface gigabitEthernet 3/3
SW3(config-if)#switchport trunk encapsulation dot1q
SW3(config-if)#switchport mode trunk

 
 
 
Cisco IOSカテゴリーのトップページは、Cisco IOSです。