CiscoIOS練習1(IP設定)
以下サイトを参考にCisco シミュレータ Packet Tracerを導入することをおススメします。(当サイトでも、Packet TracerのPKTファイルを共有していく予定です。)
Cisco シミュレータ Packet Tracer のインストール

Cisco機器の操作練習をするための、練習課題になります。

1つ目に(イ)IPアドレッシングに取り組んでください。
2つ目に(ロ)インターフェース設定に取り組んでください。

3つ目に(ハ)スタティックルート設定に取り組んでください。
4つ目に(ニ)動的ルーティング(RIP)に取り組んでください。

(イ)IPアドレッシング

以下 各題材の xxx 部分を埋める形で、IPアドレスを割り振ってください。

例題

IPアドレッシングの例題

ここをクリックして記載例を表示してみてください。

(答え)
インターフェース設定の例題

 
Cisco Packt Tracer用のPKTファイル:ip_addressing1.pktをダウンロード

題材(1)

【実技課題】IPアドレッシング1
 
Cisco Packt Tracer用のPKTファイル:ip_addressing_p01.pktをダウンロード

題材(2)

【実技課題】IPアドレッシング2
Cisco Packt Tracer用のPKTファイル:ip_addressing_p02.pktをダウンロード

題材(3)

【実技課題】IPアドレッシング3
Cisco Packt Tracer用のPKTファイル:ip_addressing_p03.pktをダウンロード

題材(4)

※今回はアドレス変換はしない。
【実技課題】IPアドレッシング4
Cisco Packt Tracer用のPKTファイル:ip_addressing_p04.pktをダウンロード

題材(5)

【実技課題】IPアドレッシング5
Cisco Packt Tracer用のPKTファイル:ip_addressing_p05.pktをダウンロード

題材(6)

※今回はアドレス変換はしない。
【実技課題】IPアドレッシング6
Cisco Packt Tracer用のPKTファイル:ip_addressing_p06.pktをダウンロード

(ロ)インターフェース設定

以下 各題材について、実機もしくはPacket Tracer等を利用して、インターフェースにIPアドレスを設定してください。また、隣接機器同士でping等を用いて疎通確認をしてください。
※1つ目の(イ)IPアドレッシングで作った成果物をご利用いただけます。(イ)をスキップした場合は以下をご利用ください。 また、ルーティングの設定は(ハ)になります。

例題

インターフェース設定の例題
左記をクリックして【IOS】インタフェースの設定 https://network00.net/iosinterface/ のページをご覧ください。

Cisco Packt Tracer用のPKTファイル:interface1.pktをダウンロード

設定例

R1

enable
vlan database
vlan 10
exit

configure terminal

interface GigabitEthernet0/1/0
no shutdown
switchport mode access
switchport access vlan 10
exit

interface GigabitEthernet0/0/0
ip address 192.168.20.1 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.30.1 255.255.255.0
no shutdown
exit

interface vlan10
ip address 192.168.10.1 255.255.255.0
no shutdown
exit

end

R2

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.40.1 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.20.2 255.255.255.0
no shutdown
exit

end

R3

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.50.1 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.30.2 255.255.255.0
no shutdown
exit

end

通信確認の例

PC1

ping 192.168.10.1
ping 192.168.20.1

PC2

ping 192.168.40.1
ping 192.168.20.2

PC3

ping 192.168.50.1
ping 192.168.30.2

R1

ping 192.168.20.2
ping 192.168.30.2

題材(1)

インターフェース設定1

Cisco Packt Tracer用のPKTファイル:interface_p01.pktをダウンロード

以下設定例ですが、極力見ずに行いましょう。

設定例

RT-WK

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.193.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.192.1 255.255.255.0
no shutdown
exit

end

RT-MT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.129.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.128.1 255.255.255.0
no shutdown
exit

end

RT-A

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.192.2 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.128.2 255.255.255.0
no shutdown
exit

end

通信確認の例

PC1

ping 192.168.193.254
ping 192.168.192.1

PC2

ping 192.168.129.254
ping 192.168.128.1

RT-A

ping 192.168.192.2
ping 192.168.192.1
ping 192.168.128.2
ping 192.168.128.1

題材(2)

インターフェース設定2

Cisco Packt Tracer用のPKTファイル:interface_p02.pktをダウンロード

以下設定例ですが、極力見ずに行いましょう。

設定例

ART

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 10.10.10.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 10.20.20.253 255.255.255.0
no shutdown
exit

end


BRT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 10.20.20.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 10.30.30.1 255.255.255.0
no shutdown
exit

end


CRT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 10.40.40.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 10.30.30.254 255.255.255.0
no shutdown
exit

end

通信確認の例

A1PC

ping 10.10.10.254
ping 10.20.20.253

C1PC

ping 10.40.40.254
ping 10.30.30.254

BRT

ping 10.20.20.254
ping 10.20.20.253
ping 10.30.30.1
ping 10.30.30.254

題材(3)

インターフェース設定3

Cisco Packt Tracer用のPKTファイル:interface_p03.pktをダウンロード

以下設定例ですが、極力見ずに行いましょう。

設定例

XRT

enable
configure terminal

interface GigabitEthernet0/0/1
ip address 172.16.241.254 255.255.255.0
no shutdown
exit

interface Vlan1
ip address 172.16.242.1 255.255.255.0
no shutdown
exit

end


Net1RT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 172.16.241.253 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 172.16.240.254 255.255.255.0
no shutdown
exit

end


Net2RT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 172.16.240.253 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 172.16.208.254 255.255.255.0
no shutdown
exit

interface Vlan1
ip address 172.16.225.254 255.255.255.0
no shutdown
exit

end


WRT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 172.16.226.1 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 172.16.225.253 255.255.255.0
no shutdown
exit

end


ORT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 172.16.208.253 255.255.255.0
no shutdown
exit

interface Vlan1
ip address 172.16.209.1 255.255.255.0
no shutdown
exit

end

通信確認の例

Web.sv

ping 172.16.242.1
ping 172.16.241.254

W.pc

ping 172.16.226.1
ping 172.16.225.253

O.pc

ping 172.16.209.1
ping 172.16.208.253

Net1RT

ping 172.16.241.253
ping 172.16.241.1
ping 172.16.240.254
ping 172.16.240.253

Net2RT

ping 172.16.225.254
ping 172.16.225.253
ping 172.16.208.254
ping 172.16.208.253

題材(4)

※今回はアドレス変換はしない。
インターフェース設定4

Cisco Packt Tracer用のPKTファイル:interface_p04.pktをダウンロード

以下設定例ですが、極力見ずに行いましょう。

設定例

Floor1RT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.129.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.128.2 255.255.255.0
no shutdown
exit

end

CenterRT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.128.1 255.255.255.0
no shutdown

interface Vlan1
ip address 192.168.64.1 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.32.2 255.255.255.0
no shutdown
exit

end

Floor2RT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.65.254 255.255.255.0
no shutdown

interface GigabitEthernet0/0/1
ip address 192.168.64.2 255.255.255.0
no shutdown
exit

end

EntranceRT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.32.1 255.255.255.0
no shutdown
exit

interface Vlan1
ip address 20.xxx.18.129 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 20.xxx.17.1 255.255.255.0
no shutdown
exit

end

ISPRT

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 20.xxx.17.2 255.255.255.0
no shutdown
exit

end

通信確認の例

F1-1.pc

ping 192.168.129.254
ping 192.168.128.2

F2.pc

ping 192.168.65.254
ping 192.168.64.2

AServer

ping 20.xxx.18.129
ping 20.xxx.17.1

CenterRT

ping 192.168.128.1
ping 192.168.128.2
ping 192.168.64.1
ping 192.168.64.2

EntranceRT

ping 192.168.32.1
ping 192.168.32.2
ping 20.xxx.17.1
ping 20.xxx.17.2

題材(5)

インターフェース設定5

Cisco Packt Tracer用のPKTファイル:interface_p05.pktをダウンロード
以下設定例ですが、極力見ずに行いましょう。

設定例

RT-1

enable
configure terminal

interface Vlan1
ip address 192.168.11.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.12.1 255.255.255.0
no shutdown
exit

end

RT-2

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.12.2 255.255.255.0
no shutdown

interface Vlan1
ip address 192.168.22.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.23.1 255.255.255.0
no shutdown
exit

end

RT-3

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.23.2 255.255.255.0
no shutdown

interface Vlan1
ip address 192.168.33.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.34.1 255.255.255.0
no shutdown
exit

end

RT-4

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.34.2 255.255.255.0
no shutdown
exit

interface Vlan1
ip address 192.168.44.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.45.1 255.255.255.0
no shutdown
exit

end

RT-5

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.45.2 255.255.255.0
no shutdown
exit

interface Vlan1
ip address 192.168.55.254 255.255.255.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 192.168.56.1 255.255.255.0
no shutdown
exit

end

RT-6

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 192.168.56.2 255.255.255.0
no shutdown
exit

interface Vlan1
ip address 192.168.66.254 255.255.255.0
no shutdown
exit

end

通信確認の例

F1-Work

ping 192.168.11.254
ping 192.168.12.1

F2-Work

ping 192.168.22.254
ping 192.168.12.2
ping 192.168.23.1

F3-Work

ping 192.168.33.254
ping 192.168.23.2
ping 192.168.34.1

F4-Work

ping 192.168.44.254
ping 192.168.34.2
ping 192.168.45.1

F5-Work

ping 192.168.55.254
ping 192.168.45.2
ping 192.168.56.1

F6-Work

ping 192.168.66.254
ping 192.168.56.2

RT-2

ping 192.168.12.1
ping 192.168.23.2

RT-4

ping 192.168.34.1
ping 192.168.45.2

RT-6

ping 192.168.56.1

題材(6)

※今回はアドレス変換はしない。
インターフェース設定6

Cisco Packt Tracer用のPKTファイル:interface_p06.pktをダウンロード
以下設定例ですが、極力見ずに行いましょう。

設定例

こちらをクリックし、設定例を表示できます。

A-Router


enable
configure terminal

interface GigabitEthernet0/0/0
ip address 172.16.0.1 255.255.0.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 172.30.0.1 255.255.0.0
no shutdown
exit

end

B-Router


enable
configure terminal

interface GigabitEthernet0/0/0
ip address 172.17.0.1 255.255.0.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 172.30.0.2 255.255.0.0
no shutdown
exit

end

SV1-Router

enable
configure terminal

interface Vlan1
ip address 172.18.17.0 255.255.0.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 172.20.10.0 255.255.0.0
no shutdown
exit

interface GigabitEthernet0/0/0
ip address 172.30.255.254 255.255.0.0
no shutdown
exit

end

SV2-Router

enable
configure terminal

interface Vlan1
ip address 172.19.255.1 255.255.0.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 172.20.10.1 255.255.0.0
no shutdown
exit

interface GigabitEthernet0/0/0
ip address 172.30.255.253 255.255.0.0
no shutdown
exit

end

Edge-Router

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 172.20.10.2 255.255.0.0
no shutdown
exit

interface GigabitEthernet0/0/1
ip address 199.xxx.0.101 255.255.255.0
no shutdown
exit

end

ISP

enable
configure terminal

interface GigabitEthernet0/0/0
ip address 199.xxx.0.102 255.255.255.0
no shutdown
exit

end

通信確認の例

A1.pc

ping 172.16.0.1
ping 172.30.0.1

B1.pc

ping 172.17.0.1
ping 172.30.0.2

mobile1

ping 172.18.17.0
ping 172.30.255.254
ping 172.20.10.0

mobile2

ping 172.19.255.1
ping 172.30.255.253
ping 172.20.10.1

A-Router

ping 172.30.0.2
ping 172.30.255.254
ping 172.30.255.253

Edge-Router

ping 172.20.10.2
ping 172.20.10.0
ping 172.20.10.1
ping 199.xxx.0.101
ping 199.xxx.0.102