iosetherchannel

目次

イーサチャネル(リンクアグリゲーション)の概要

  • 複数のポート(とその間のケーブル)接続を1個(本)での接続と見なす。
  • 性能や信頼性を向上させる冗長化技術である。
  • 名前の通り、イーサネットで用いられる技術
  • スイッチ(CatalystやCisco以外のスイッチ)同士の接続で良く使用される。
  • サーバーやルーター等にもリンクアグリゲーション機能が備わっている。
  • 対抗機器と合う様に設定を行う必要がある。
  • 一般的にはIEEE802.3adが普及している。(現行規格はIEEE802.1AX-2008。)
    • staticとLACPがあり、どちらかを選択する。
    • staticは最大8ポートまで束ねることができる。
    • LACPを使う場合、最大16個まで指定することができるが、8 本がアクティブで、残りの8 本はスタンバイ(通信はされず待機している状態) になる。
    • LACPの場合、アクティブが1本不通・不調(リンクダウンしていなくても)になったら、その1本はスタンバイへ切り替わる。

イーサチャネル(リンクアグリゲーション)の設定コマンド

イーサチャネルの設定

  (config)#interface range [interface-id, interface-id, ・・・]
  (config-if-range)#switchport ※デフォルトなので省略可
  (config-if-range)#channel-group [group-number] mode [desirable|auto|active|passive|on]
  (config-if-range)#no shutdown ※デフォルトなので省略可

  interface-id   : インタフェース
  group-number  : イーサチャネルのグループ番号
  desirable | auto : PAgP
  active | passive : LACP
  on       : static

イーサチャネルの設定後にVLANを割り当て

  (config)#interface port-channel [group-number]
  (config-if)#switchport ※デフォルトなので省略可
  (config-if)#switchport trunk encapsulation dot1q ※機種によって省略可
  (config-if)#switchport trunk allowed vlan [vlan-id],[vlan-id],・・・
  (config-if)#switchport mode trunk

イーサチャネルの設定の確認

#show etherchannel summary
Flags: D – down P – in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator
u – unsuitable for bundling
w – waiting to be aggregated
d – default port

Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
——+————-+———–+———————————————-

1  Po1(SD)    LACP  Gig0/1(I) Gig0/2(I)

イーサチャネル(リンクアグリゲーション)の設定の例

SW1の設定

>enable
#configure terminal

(config)#interface range GigabitEthernet0/1-2
(config-if-range)#channel-group 1 mode active
(config-if-range)#exit

(config)#interface port-channel 1
(config-if)#switchport trunk allowed vlan 10,20
(config-if)#switchport mode trunk
(config-if)#no shutdown
(config-if)#end

SW2の設定

>enable
#configure terminal

(config)#interface range GigabitEthernet0/1-2
(config-if-range)#channel-group 2 mode active
(config-if-range)#exit

(config)#interface port-channel 2
(config-if)#switchport trunk allowed vlan 10,20
(config-if)#switchport mode trunk
(config-if)#no shutdown
(config-if)#end

SW3の設定

>enable
#configure terminal

(config)#interface range GigabitEthernet1/0/1-2
(config-if-range)#channel-group 1 mode active
(config-if-range)#exit

(config)#interface range GigabitEthernet1/0/3-4
(config-if-range)#channel-group 2 mode active
(config-if-range)#exit

(config)#interface port-channel 1
(config-if)#switchport trunk encapsulation dot1q
(config-if)#switchport trunk allowed vlan 10,20
(config-if)#switchport mode trunk
(config-if)#no shutdown
(config-if)#exit

(config)#interface port-channel 2
(config-if)#switchport trunk encapsulation dot1q
(config-if)#switchport trunk allowed vlan 10,20
(config-if)#switchport mode trunk
(config-if)#no shutdown
(config-if)#end

 
Cisco IOSカテゴリーのトップページは、Cisco IOSです。